Saturday, September 16, 2006

Instructions for the CardSpace FirefFox Extention

It sounds like Craig Burton has been having trouble with the demo Cardspace Selector I put together for Firefox. I'm not sure what trouble he's been having, but I thought I'd toss up some quick instructions, and a screen cast.

Step 1) Make sure you're on Firefox 1.5 or greater.

Step 2) Make sure you've got J2SE 1.4x installed on your machine. The xmldap selector doesn't use any .net or Microsoft code...its a cross platform implementation written from scratch in Java. You can hit http://java.sun.com if you need to download a JDK

Step 3) Go to http://xmldap.org and download the Firefox extension. You may need to allow the popup blocker to trust my site. Restart firefox.

Step 4) Go to a Cardspace enabled site like xmldap, identityblog, or ping

Step 5) Click to login, create a card, and submit.

Note that you'll still get a warning saying: "Additional plugins are required to display all the media on this page" Ignore it...I haven't figured out how to make it go away yet. Please email me or comment if you know!


Craig and others - email me at cmort at xmldap.org if you have questions or issues!

5 comments:

WaKkO said...

I have installed:

- .net framework 3.0 RC1
- Firefox 1.5.0.7
- J2SE Development Kit 5.0 Update 7
- J2SE Runtime Environment Update 7

and when i click the infcard logo on identityblog, pingidentity or sandbox, i just get that warning about missing plugins, but nothing else happens. I don't get the identity selector window like in the screen capture you posted :S

WaKkO said...

I have installed:

- .net framework 3.0 RC1
- Firefox 1.5.0.7
- J2SE Development Kit 5.0 Update 7
- J2SE Runtime Environment Update 7

and when i click the infcard logo on identityblog, pingidentity or sandbox, i just get that warning about missing plugins, but nothing else happens. I don't get the identity selector window like in the screen capture you posted :S

cmort said...

Per step 2, I've only ever tested with JDK 1.4. The cryypto provider we're using is specific to 1.4 so perhaps there are some compat issues.

Note that there is no need to have .net installed.

Stokes said...

I am currently trying this with Firefox 2.0 (and the site only says 1.5+ - so wasn't sure if that meant anything higher than 1.5 or not), but it errored out telling me that it is not supported on 2.0, but that I need something between 0.9 and 1.5+. Are there plans to make this available for 2.0 since it has been released? Also, not to be nitpicky, but saying it supports 1.5+, but then can't support 2.0 seems a little misleading on the error message.

cmort said...

We haven't yet taken a look at Firefox 2.0, but it's on the list.

And yeah...that's a little nit-picky. The plugin was released long before Firefox 2.0, so we were unable to predict that they would break back-compat on us.

We'll get to it soon though.